Undead Sleds - Hot Rods, Rat Rods, Beaters & Bikes... since 2007!

Go Back   Undead Sleds - Hot Rods, Rat Rods, Beaters & Bikes... since 2007! > Frame/Suspension/Brake... Talk & Q&A

Frame/Suspension/Brake... Talk & Q&A All things... Frame/Suspension/Brake

Reply
 
Thread Tools Display Modes
  #31  
Old 06-14-2017, 04:53 PM
DozerII's Avatar
DozerII DozerII is offline
Rusty Rat Rodder
 
Join Date: Sep 2015
Location: Saskatchewan Can.
Posts: 1,374
Default

99% sure the problem is solved, everyone has told me it is the master cyl, after two new ones and still having the same problem I was doubtful. But my experience with brakes was saying the same thing. I was about to pull trigger on a third on and deicided to try the replacement Prop valve that Summit sent me. After the install and carefully bleeding all the air out I went for a test drive and I can't believe the difference in the brakes. I though they were good before despite the problem now they are awesome.
__________________
Glen
My 29 Essex Build http://ratrodsrule.com/forum/showthread.php?t=34026

Don't give up, it's far too much fun once you can drive it.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:05 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Rat Rods Rule Inc.