Undead Sleds - Hot Rods, Rat Rods, Beaters & Bikes... since 2007!

Go Back   Undead Sleds - Hot Rods, Rat Rods, Beaters & Bikes... since 2007! > Frame/Suspension/Brake... Talk & Q&A

Frame/Suspension/Brake... Talk & Q&A All things... Frame/Suspension/Brake

Reply
 
Thread Tools Display Modes
  #1  
Old 08-17-2017, 10:12 PM
vinman vinman is offline
Junior Member
 
Join Date: Apr 2015
Posts: 28
Default chassis engineering

anybody using there rear leaf springs on 1935 to40 fat fender ford ? I have 37 slantback I missed on spring setup BAD rides like a rock..had it to spring shop today and he told I will never get any kind of ride with the springs I have in it .im looking at the springs CE offers 48 eye to eye center pin at 24 that is what I need thay are 5 leaf 3inch ark.. anybody using them ?? any input will help guys don't need to make wrong move ... thanks vince
Reply With Quote
  #2  
Old 08-17-2017, 10:18 PM
Tripper's Avatar
Tripper Tripper is offline
Older and more rusted every day!
 
Join Date: May 2007
Location: Central Tejas
Posts: 11,099
Default

I used Chassis Engineering Inc's rear leaf springs on my truck but took one leaf out! Works fine!

BoB
__________________
Rust... Mother Nature's paint job... don't fool with Mother Nature!

RRR on Facebook
RRR on Twitter
Wanted: Ratty '35 Olds coupe!
Reply With Quote
  #3  
Old 08-17-2017, 10:26 PM
vinman vinman is offline
Junior Member
 
Join Date: Apr 2015
Posts: 28
Default springs

thanks brother that's what I wanted to here !!! did you get the HD springs? did it have 5 leafs?
Reply With Quote
  #4  
Old 08-18-2017, 07:33 AM
Blue Eyed Devil's Avatar
Blue Eyed Devil Blue Eyed Devil is offline
Devil's Advocate
 
Join Date: Mar 2008
Location: Dayton, OHIO
Posts: 2,162
Default

Why don't you just set it up properly with the spring you have? I am assuming you didn't have the correct shackle angle when you did the mounts?
__________________
I'm the dirty dozen for the price of one...
Reply With Quote
  #5  
Old 08-18-2017, 07:47 AM
vinman vinman is offline
Junior Member
 
Join Date: Apr 2015
Posts: 28
Default spring

na ..there mounted ok the springs are to heavy..springs are out of dodge 4x4 he just told me to thick ..to flat. it had 3 ..I pulled 2 out ,and its still hard
Reply With Quote
  #6  
Old 08-18-2017, 08:24 AM
Old Iron's Avatar
Old Iron Old Iron is offline
Rusty Rat Rodder
 
Join Date: May 2011
Location: Willard Mo.
Posts: 8,800
Default

I've used their leaf spring kits on several and the one I use is the universal kit.
Here's an example and it rides great.

Attached Images
File Type: jpg IMG_6776.jpg (80.5 KB, 46 views)
Reply With Quote
  #7  
Old 08-18-2017, 09:06 AM
bruno's Avatar
bruno bruno is offline
Crusty Rusty Old Rat Rodder!
 
Join Date: Jan 2010
Location: harrodsburg ky
Posts: 1,677
Default

In 1988 I used their complete rear end kit and sway bar on the rear of my 37 slantback. It rode and handled like a dream. Also had their front end kit, axle, spring and split wishbone kit. Used their trans x-member kit also. You can't get any better quality parts.
__________________
_______________________________________
The smoker you drink, the player you get.....Joe Walsh
Reply With Quote
  #8  
Old 08-18-2017, 09:50 AM
bob w bob w is offline
Still crazy after all these years!
 
Join Date: Jan 2008
Location: Stillwater, MN
Posts: 8,308
Default

I helped install the rear parallel leaf spring kit in a 1936 Ford coupe. Was easy with the body off.
Make sure they have what you want in stock. A friend of mine waited 6 months for out of stock springs.
Reply With Quote
  #9  
Old 08-18-2017, 02:28 PM
Blue Eyed Devil's Avatar
Blue Eyed Devil Blue Eyed Devil is offline
Devil's Advocate
 
Join Date: Mar 2008
Location: Dayton, OHIO
Posts: 2,162
Default

Quote:
Originally Posted by vinman View Post
na ..there mounted ok the springs are to heavy..springs are out of dodge 4x4 he just told me to thick ..to flat. it had 3 ..I pulled 2 out ,and its still hard
Ah ok. Well no wonder they don't flex!

I thought you were running the stock Ford spring. Disregard...
__________________
I'm the dirty dozen for the price of one...
Reply With Quote
  #10  
Old 08-18-2017, 04:24 PM
forbigpicture's Avatar
forbigpicture forbigpicture is offline
Please stand by.......
 
Join Date: Mar 2014
Location: West by God Virginia
Posts: 4,002
Default

I had a couple of CE spring kit's one on a 40 Ford pu and one on
my 48 Ford sedan it also uses 3 in blocks, can't tell you how they
ride though as I sold one and haven't finish the other... couple other friends have used them also and had good luck with them with a decent ride....

129.jpg
Attached Images
File Type: jpg 127.jpg (62.9 KB, 35 views)
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 01:04 AM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Rat Rods Rule Inc.