Undead Sleds / Rat Rods Rule - Hot Rods, Rat Rods, Sleepers, Beaters & Bikes... since 2007!

Go Back   Undead Sleds / Rat Rods Rule - Hot Rods, Rat Rods, Sleepers, Beaters & Bikes... since 2007! > Frame/Suspension/Brake... Talk & Q&A

Frame/Suspension/Brake... Talk & Q&A All things... Frame/Suspension/Brake

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 05-13-2019, 05:56 PM
dmw56's Avatar
dmw56 dmw56 is offline
Busted and Rusted on Route 66
 
Join Date: Dec 2007
Location: Edgewood, New Mexico off Route 66
Posts: 6,134
Default Drum brake problem!

I'm to the point of bleeding the brakes and seeing what I've got. So far the front discs are working but the back drums aren't.

There is a small amount of fluid coming out of the wheel cylinders but not enough to move the cylinders. I've bled them several times and I'm not getting any air.

I've checked all connections for leaks and fixed them. The vacuum is not hooked up engine isn't running yet. That shouldn't be an issue but I could be wrong. Wrong master and valve?? I'm stumped any suggestions please. Thanks guys!

This is what I have. GM disc/drum master cylinder with 7" dual power assist. Front brakes hooked up to the front reservoir and rear drums to rear. Hope that's right?



GM proportioning valve hopefully it's a disc/drum.


9 1/2" GM brakes new wheel cylinders and shoes
__________________
dmw...Livin' on Route 66

"No matter how smart you are you can never convince someone stupid that they are stupid."

34 Ford Coupe
51 Ford F1
50 Stude Champ
Intro
Reply With Quote
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



All times are GMT -5. The time now is 02:06 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Rat Rods Rule Inc.