65 GTO LS swap

Rat Rods Rule

Help Support Rat Rods Rule:

This site may earn a commission from merchant affiliate links, including eBay, Amazon, and others.

Old Iron

Well-known member
Joined
May 19, 2011
Messages
15,220
Location
Willard Mo.
Well I took the 1075 horse big block (on nitrous) out sold it to a friend for his 67 Nova SS and sold the JW powerglide to another friend of mine for his pro street Gremlin I built him.
It's a 6.2 all aluminum LS out of a 2012 Camaro with a 4l80e tranny.
Got the engine positioned and lifted the tranny into the tunnel to find that I'm gonna have to enlarge the tunnel for it to fit.
We've been using the factory ecms and an aftermarket harness for our swaps.
This engine required both the ecm and a tcm (transmission control module) which I didn't receive the tcm with the pullout so, I purchased a Holley Terminator X Max that will control both the engine and tranny.

attachment.php

attachment.php

attachment.php

attachment.php

attachment.php
 

Attachments

  • 20230205_103637.jpg
    20230205_103637.jpg
    159.6 KB · Views: 79
  • 20230205_103647.jpg
    20230205_103647.jpg
    152.9 KB · Views: 79
  • 20230205_103655.jpg
    20230205_103655.jpg
    175.2 KB · Views: 78
  • 20230205_103703.jpg
    20230205_103703.jpg
    154.1 KB · Views: 78
  • 20230205_103707.jpg
    20230205_103707.jpg
    144.2 KB · Views: 77
Welcome to hot rodding in 2023. The results will be terrific! Did you get the engine and trans out of a wrecked Camaro? What horsepower?
 
Welcome to hot rodding in 2023. The results will be terrific! Did you get the engine and trans out of a wrecked Camaro? What horsepower?

Thanks y'all
The engine came out of a Camaro, the tranny did not, it was performance built by a friend of mine DNJ Performance Transmissions.
The engine started out as the 400 horse with VVT and DOD which I deleted because, the Holley unit will not control the VVT and we all know about how DOD will fail.
I went ahead and rebuilt it, it only had 80,000 on it, then added a Brian Tooley stage 2 cam.
I got the tranny tunnel clearanced yesterday and the engine positioned. I used Dirty Ding engine mounts with clamshell style rubber lowers that mount to the frame.
 
Had a busy week but, managed to get a little more done.
The engine and tranny were installed for the last time.
attachment.php

attachment.php

attachment.php
 

Attachments

  • 20230210_134645.jpg
    20230210_134645.jpg
    141.2 KB · Views: 46
  • 20230210_134651.jpg
    20230210_134651.jpg
    140.5 KB · Views: 45
  • 20230210_134655.jpg
    20230210_134655.jpg
    149.5 KB · Views: 48
Only bad thing about those is the fuguly intake. I’ve seen some with “ valve cover covers” that hide the coils and look like an older SBC. The Coyote Ford is just as ugly. Can’t discount the power they put out though!
 
I've been watching the LS into a Chevelle swap on Vice Grip Garage on You Tube.

Your swap should be killer.
 
This is one of the problems of leaving a vehicle set too long.
The headliner was full of their nest too :mad:
attachment.php
 

Attachments

  • 20230218_142624.jpg
    20230218_142624.jpg
    115.2 KB · Views: 47
Them critters will ruin a good car in no time. Think you have one sealed up, but they can get through the tiniest of holes. Hope they didn’t destroy yours too bad before you found they were in there.
 
^^^ agree with Bama! Check your wiring too. Besides nests, they like to chew on the wire coverings. I have a tractor waiting on some wire repairs due to this issue. Goat looks good OI!
 
I laid under the dash for a couple hours yesterday going over all the wiring, thank God they didn't chew any of it up.
 
Got the swap done and then spent 5 days lookin into why it wouldn't start :(
I had Casey, the young man that works with me and a friend that has installed over 40 of these Holley Terminator X systems and none of us could figure it out.
After going through all the wiring and checking the pinouts of the sensor plugs and computer with no avail, Casey noticed that the alternator wasn't turning over and the belt wasn't moving. Low and behold, I had the serpentine idler pulley locked up on a bolt behind it and it was causing the starter to drag enough the injectors and the coils wouldn't fire, even after I installed a 1,200 cranking amp battery.
After fixing the pulley it fires right off [S
A local muffler shop done an outstanding job on my 3" exhaust system and it took 4 mufflers to keep it from being extremely loud.

attachment.php

attachment.php

attachment.php
 

Attachments

  • 20230323_091655.jpg
    20230323_091655.jpg
    135.5 KB · Views: 28
  • 20230323_091714.jpg
    20230323_091714.jpg
    150.4 KB · Views: 29
  • 20230323_091721.jpg
    20230323_091721.jpg
    152 KB · Views: 28
Casey noticed that the alternator wasn't turning over and the belt wasn't moving. Low and behold, I had the serpentine idler pulley locked up on a bolt behind it and it was causing the starter to drag enough the injectors and the coils wouldn't fire, even after I installed a 1,200 cranking amp battery.

The alt actually froze up on the LS3 in my Chevelle & wouldn't start. I tried everything & finally had to take it in & they figured it out. Never had that happen before or since!

Swap looks great & should be a beast on da streets!!!

BoB
 
Glad you got the tech problems solved. The exhaust system looks great. Should be areal performer.
 
Well, I took the GTO to a friend of mines hub dyno today, I was pleased with the Hp and torque it put out.

attachment.php


First pull
attachment.php


After 5 pulls and tuning between each one
attachment.php
 

Attachments

  • 20230326_112953.jpg
    20230326_112953.jpg
    152.4 KB · Views: 15
  • 20230326_122733.jpg
    20230326_122733.jpg
    146.4 KB · Views: 15
  • 20230326_105138.jpg
    20230326_105138.jpg
    148.1 KB · Views: 16

Latest posts

Back
Top